Supported browsers

While we make our best effort to support older versions of browsers wherever possible, we can only support the latest version. We highly recommend for your security that, whatever browser you use, you set it to automatically update to the latest version. Using older software, including older browsers, can be a security risk for your computer.

We support the latest versions of:

To use our web interface, you must have:

Cookies are small snippets of information stored on your computer and sent back to our server with each request. Like all sites, we use these as part of our system for signing in securely. Our site does not have any ads: the only cookies set are from us and we do not use cookies for any other purpose other than authentication.

On mobile

We support the Android 5 operating system or later, as well as iOS 9 or later.